Discussions  >  CollabNet Subversion Admins  >  Re: Edge on Debian squeeze doesn't start SVN server

Back to topic list

Re: Edge on Debian squeeze doesn't start SVN server

Author markphip (OCN Member)
Full name Mark Phippard
Date 2012-02-27 08:30:14 PST
Message On Feb 27, 2012, at 11:20 AM, Luca Matteini wrote:

> I installed a test appliance on a basic Debian squeeze (running atop a Proxmox virtual environment), and almost everything works fine till now, besides subversion server start.
> When I connect to the console I am notified Subversion server is down (and it really is unavailable), then as I click on "Start" it... starts.
> Shouldn't it be already up?
> What can be missing?
> Any evidence I can look for in the logs?
>
> Another note: I had to modify installation, and reinstall the init scripts, since they were linked only to runlevel 3 and 5.
> First, with an 'update-rc.d -f csvn remove' I removed the links, then with an 'update-rc.d csvn defaults' reinstalled the (proper?) ones.
> I'm just not sure the dependency level specified in the 'csvn' script as
> # Required-Start: $local_fs $network $syslog
> is enough. So I changed it to
> # Required-Start: $all $local_fs $network $syslog
> Sounds reasonable? (...)

Just so that I understand ... what you are saying is that the server pretty much works OK, but what is not working is when the server reboots the Apache httpd server is not being restarted automatically?

Did you run the script to install it?

$ sudo -E bin/csvn-httpd install

The "csvn" script only governs the start of the Subversion Edge console.

Mark

« Previous message in topic | 2 of 4 | Next message in topic »

Messages

Show all messages in topic

Edge on Debian squeeze doesn't start SVN server loucypherr (OCN Member) Luca Matteini 2012-02-27 08:20:25 PST
     Re: Edge on Debian squeeze doesn't start SVN server markphip (OCN Member) Mark Phippard 2012-02-27 08:30:14 PST
         RE: Re: Edge on Debian squeeze doesn loucypherr (OCN Member) Luca Matteini 2012-02-27 10:20:26 PST
             Re: Edge on Debian squeeze doesn markphip (OCN Member) Mark Phippard 2012-02-27 10:26:26 PST
Messages per page: