Discussions  >  CollabNet Subversion Admins  >  Re: Java Exception when trying to update

Back to topic list

Re: Java Exception when trying to update

Author markphip (OCN Member)
Full name Mark Phippard
Date 2012-03-13 09:46:23 PDT
Message On Mar 13, 2012, at 12:38 PM, C Burch wrote:

> I'm trying to update Subversion Edge from 2.0.0 to 2.3.0 (and binaries from 1.6.17 to 1.7.3) on Windows Server 2008 R2 Enterprise, 64 bit. When I run the "Install Updates" in the web interface nothing happens and I get the following in the console.log:
>
> Exception in thread "Csvn Installer Daemon" java.lang.RuntimeException: package installed more than once: pkg://collab.net/XXX​X@XXXX,6.1.7600-2899​.88:20120227T181713Z​
> at com.sun.pkg.client.I​mage.getVersionInsta​lled(Image.java:1816​)
> ...
> etc. etc.
>
> And, indeed, when I look in the web interface under "Installed Packages," CollabNet Subversion Edge 2.0.0 is listed twice; the Date, Release, Build and Size are all identical. I have no idea how it got that way.
>
> I'm wondering how I can remove one of the listings... or should I just re-install 2.3.0 over the top of it?

If you follow the instructions in this wiki page to do a manual upgrade it should resolve the problem:

https://ctf.open.col​lab.net/sf/wiki/do/v​iewPage/projects.svn​edge/wiki/ManualUpgr​ade

I would suggest using the more detailed approach shown in the wiki where you do an uninstall/cleanup/reinstall and please note the bug info on that page and backup your svn_access_file.

Mark

« Previous message in topic | 2 of 3 | Next message in topic »

Messages

Show all messages in topic

Java Exception when trying to update cburch (OCN Member) C Burch 2012-03-13 09:38:37 PDT
     Re: Java Exception when trying to update markphip (OCN Member) Mark Phippard 2012-03-13 09:46:23 PDT
         RE: Re: Java Exception when trying to update cburch (OCN Member) C Burch 2012-03-13 09:55:17 PDT
Messages per page: