Discussions  >  CollabNet Subversion Admins  >  Apache service fails to start after install on Windows

Back to topic list

Apache service fails to start after install on Windows

Author kanngard (OCN Member)
Full name Johan Kanngard
Date 2010-09-07 02:11:18 PDT
Message Steps to reproduce:
Windows 2003 Server SP2
Java 1.6.0_20 installed on default location C:\Program Files\Java\jre6\
PATH updated with C:\Program Files\Java\jre6\bin
JAVA_HOME set to C:\Program Files\Java\jre6
Machine restart
Installation of CollabNet Subversion Edge 1.1.0 with default options to c:\csvn
Opened C:\csvn\launch.html in browser, displays Console Status: Not Ready
Event Viewer says "The Apache service named reported the following error:
>>> httpd.exe: Could not open configuration file D:/csvn/data/conf/httpd.conf: The system cannot find the file specified."
If I open a console and enter java -version, it works:
java version "1.6.0_20"
Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
Java HotSpot(TM) Client VM (build 16.3-b01, mixed mode, sharing)
The CollabNet Subversion Edge service starts OK
No logs in c:\cvsn\data\logs
Tried starting the console manually but it isn't listening, the following is printed when runConsole.bat is started:
C:\csvn\svcwrapper\bat>call setenv.bat
"C:\Program Files\Java\jre6\bin\java" -Xmx30m -jar "C:\csvn\svcwrappe​r\bat\..\wrapper.​jar" -c "C:\csvn\svcwrapper\bat\..
\conf\wrapper.conf"
2010-sep-07 11:04:17 org.apache.commons.vfs.VfsLog info
INFO: Using "h:\vfs_cache" as temporary files store.
init
INFO|wrapper|10-09-07 11:04:18|set state IDLE->STARTING
INFO|wrapper|10-09-07 11:04:18|starting Process
2010-sep-07 11:04:18 org.rzo.yajsw.contro​ller.jvm.JVMControll​er start
INFO: binding error: Failed to bind to: 0.0.0.0/0.0.0.0:15003 -> retry with another port
INFO|wrapper|10-09-07 11:04:18|Controller State: UNKNOWN -> WAITING
INFO|wrapper|10-09-07 11:04:19|working dir C:\csvn\svcwrapper\..\appserver
INFO|wrapper|10-09-07 11:04:19|exec: "java" "-classpath" "/C:/csvn/svcwrapper​/./wrapperApp.jar;C:​\csvn\appserver\s​tart.j
ar" "-XX:MaxPermSize=128m" "-Djetty.home=../appserver" "-Djetty.port=3343" "-Xms64m" "-Xmx512m" "-Dwrapper.config=C:\csv
n\svcwrapper\conf\wrapper.conf" "-Dwrapper.port=15004" "-Dwrapper.key=61283​00477717716414" "-Dwrapper.teeName=6128300477
717716414$1283850259037" "-Dwrapper.tmpPath=h:\" "org.rzo.yajsw.app.W​rapperJVMMain"
INFO|wrapper|10-09-07 11:04:19|started process with pid 3248
INFO|wrapper|10-09-07 11:04:19|set state STARTING->RUNNING
INFO|3248/0|10-09-07 11:04:19|Controller State: WAITING -> PROCESS_KILLED
INFO|wrapper|10-09-07 11:04:19|set state RUNNING->STATE_ABORT
Skipping update script.
INFO|wrapper|10-09-07 11:04:19|set state STATE_ABORT->IDLE
INFO|3248/0|10-09-07 11:04:33|Controller State: PROCESS_KILLED -> STARTUP_TIMEOUT
2010-sep-07 11:04:33 org.rzo.yajsw.contro​ller.jvm.JVMControll​er logStateChange
VARNING: startup of java application timed out. if this is due to server overload consider increasing wrapper.startup.ti
meout
INFO|wrapper|10-09-07 11:04:33|set state IDLE->STATE_ABORT
Skipping update script.
INFO|wrapper|10-09-07 11:04:33|set state STATE_ABORT->IDLE


I've tried searching the net and this forum for fixing this problem, but have not found anything. Any ideas? Thanks!

« Previous message in topic | 1 of 7 | Next message in topic »

Messages

Show all messages in topic

Apache service fails to start after install on Windows kanngard (OCN Member) Johan Kanngard 2010-09-07 02:11:18 PDT
     Re: Apache service fails to start after install on Windows markphip (OCN Member) Mark Phippard 2010-09-07 06:02:22 PDT
         RE: Re: Apache service fails to start after install on Windows kanngard (OCN Member) Johan Kanngard 2010-09-07 23:22:21 PDT
             Re: Apache service fails to start after install on Windows markphip (OCN Member) Mark Phippard 2010-09-08 06:37:53 PDT
                 RE: Re: Apache service fails to start after install on Windows kanngard (OCN Member) Johan Kanngard 2010-09-08 08:53:01 PDT
                     Re: Apache service fails to start after install on Windows markphip (OCN Member) Mark Phippard 2010-09-08 09:08:30 PDT
                     Re: Apache service fails to start after install on Windows markphip (OCN Member) Mark Phippard 2010-09-08 09:41:26 PDT
Messages per page: