Discussions  >  CollabNet Subversion Client  >  Re: Mixed mode assembly is built against version ‘v2.0.50727′ C# Enterprise architect add-in

Back to topic list

Re: Mixed mode assembly is built against version ‘v2.0.50727′ C# Enterprise architect add-in

Author markphip (OCN Member)
Full name Mark Phippard
Date 2012-11-06 06:07:53 PST
Message You should ask this in the SharpSVN forum:

http://sharpsvn.open​.collab.net/ds/viewF​orumSummary.do?dsFor​umId=728



From: Tahir Nazir <XXXX@XXXX<mai​lto:XXXX@XXXX>​>
Reply-To: CollabNet Subversion Client <XXXX@XXXX<mai​lto:XXXX@XXXX>​>
Date: Monday, November 5, 2012 10:27 PM
To: CollabNet Subversion Client <XXXX@XXXX<mai​lto:XXXX@XXXX>​>
Subject: Mixed mode assembly is built against version ‘v2.0.50727′ C# Enterprise architect add-in


I am building an Enterprise Architect add-in using C#. I have to interact with SVN Repository. I am using VS2010 and SharpSVN as library to interact with SVN Repository. my Add-in work fine when I change it to .NET 3.5. But now I have to interrogate with some another add-in and that other add-in is only compatible with 4.0.
but when I change my add-in code to .NET 4.0 then it give famous error
"Mixed mode assembly is built against version 'v2.0.50727' of the runtime and cannot be loaded in the 4.0 runtime and need some configuration etc"
I have read here different topics about that problem and suggestion is to add app.config file. with the tags

<Configuration​><startup useLegacyV2RuntimeAc​tivationPolicy="true​">
  <supportedRuntime version="v4.0" sku=".NETFramework,V​ersion=v4.0"/>​</startup><run​time>
  <NetFx40_LegacySe​curityPolicy enabled="true"/>​</runtime></​Configuration>

and same like tag this from different posts. I have tried everyone but still the problem remains. I have checked that VS2010 automatically generates the config file with the filename in Debug folder automatically.
Can anyone suggest me the solution? for example my add-in name is MyAddIn so VS2010 generates MyAddIn.dll and MyAddIn.dll.config with the above mentioned tags.
But problem remain there. I am using windows 7 64 Bit.
Any Help will be highly appreciated.
Attachments

« Previous message in topic | 2 of 2 | Next message in topic »

Messages

Show all messages in topic

Mixed mode assembly is built against version ‘v2.0.50727′ C# Enterprise architect add-in tahir182 (OCN Member) Tahir Nazir 2012-11-05 19:28:00 PST
     Re: Mixed mode assembly is built against version ‘v2.0.50727′ C# Enterprise architect add-in markphip (OCN Member) Mark Phippard 2012-11-06 06:07:53 PST
Messages per page: